36 lines
954 B
Bash
36 lines
954 B
Bash
# Maintainer: BigfootACA <bigfoot@classfun.cn>
|
|
# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
|
|
# Contributor: choopm <choopm at 0pointer.org>
|
|
# Contributor: BOYPT <pentie at gmail.com>
|
|
|
|
pkgname=sunxi-tools-git
|
|
pkgver=1.4.2.r178.gdf60a46
|
|
pkgrel=1
|
|
pkgdesc="Tools to help hacking Allwinner based devices. (A10, A20, sun4i, sun7i)"
|
|
arch=(i686 x86_64 arm armv6h armv7h aarch64)
|
|
url="https://github.com/linux-sunxi/sunxi-tools"
|
|
license=(GPL-2.0-or-later)
|
|
depends=(libusb dtc glibc zlib)
|
|
makedepends=(git)
|
|
conflicts=(sunxi-tools)
|
|
provides=(sunxi-tools)
|
|
source=("git+https://gitea.classfun.cn:4443/mirrors/sunxi-tools.git")
|
|
md5sums=('SKIP')
|
|
|
|
pkgver() {
|
|
cd "${pkgname%-git}"
|
|
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
|
|
}
|
|
|
|
build() {
|
|
cd "${pkgname%-git}"
|
|
make
|
|
make misc
|
|
}
|
|
|
|
package() {
|
|
cd "${pkgname%-git}"
|
|
PREFIX="$pkgdir/usr" make install
|
|
PREFIX="$pkgdir/usr" make install-misc
|
|
}
|