31 lines
657 B
Bash
31 lines
657 B
Bash
# Maintainer: Luca Weiss <luca (at) z3ntu (dot) xyz>
|
|
# Maintainer: BigfootACA <bigfoot@classfun.cn>
|
|
|
|
pkgname=qmic
|
|
pkgver=1.0.r0.g4574736
|
|
pkgrel=2
|
|
pkgdesc="QMI IDL compiler"
|
|
arch=("aarch64")
|
|
url="https://github.com/linux-msm/qmic"
|
|
license=(BSD)
|
|
makedepends=(git)
|
|
depends=(glibc)
|
|
source=("git+https://gitea.classfun.cn:4443/mirrors/qmic.git")
|
|
md5sums=('SKIP')
|
|
|
|
pkgver() {
|
|
cd "$pkgname"
|
|
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
|
|
}
|
|
|
|
build() {
|
|
cd "$pkgname"
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd "$pkgname"
|
|
make DESTDIR="$pkgdir/" prefix=/usr install
|
|
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
|
|
}
|