41 lines
932 B
Bash
41 lines
932 B
Bash
# Maintainer: BigfootACA <bigfoot@classfun.cn>
|
|
# Maintainer: Leonidas P. <jpegxguy at outlook dot com>
|
|
# Contributor: Vincent Bernardoff <vb AT luminar.eu.org>
|
|
|
|
pkgname=mmc-utils
|
|
pkgver=r132.123fd8b
|
|
pkgrel=2
|
|
epoch=1
|
|
pkgdesc="Userspace tools for MMC/SD devices"
|
|
arch=('x86_64' 'i686' 'aarch64' 'armv7h' 'armv6h')
|
|
url="https://git.kernel.org/pub/scm/utils/mmc/mmc-utils.git"
|
|
license=('GPL')
|
|
makedepends=('git')
|
|
provides=("${pkgname}")
|
|
conflicts=("${pkgname}")
|
|
source=('git+https://gitea.classfun.cn:4443/korg/mmc-utils.git')
|
|
sha256sums=('SKIP')
|
|
|
|
pkgver() {
|
|
cd "${pkgname}"
|
|
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
|
|
}
|
|
|
|
prepare() {
|
|
cd "${pkgname}"
|
|
sed -i 's,-Werror,,g' Makefile
|
|
sed -i '/C ?= 1/d' Makefile
|
|
}
|
|
|
|
build() {
|
|
cd "${pkgname}"
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd "${pkgname}"
|
|
mkdir -p "${pkgdir}/usr/share/man/man1"
|
|
mkdir -p "${pkgdir}/usr/bin"
|
|
make DESTDIR="${pkgdir}" prefix=/usr install
|
|
}
|